<!DOCTYPE html>
<html lang="en-US">
<head>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-161204082-31"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-161204082-31');
</script>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	<title>Saudi Commission for Health Specialties® and Prometric® Open Innovative Testing Center in Riyadh | Turkey News Gazette</title>

<!-- All In One SEO Pack 3.6.2ob_start_detected [-1,-1] -->

<meta name="keywords"  content="mena,press release" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://turkeynewsgazette.com/#organization","url":"https://turkeynewsgazette.com/","name":"Turkey News Gazette","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://turkeynewsgazette.com/#logo","url":"https://turkeynewsgazette.com/wp-content/uploads/2020/06/turkeyng-logo.png","caption":""},"image":{"@id":"https://turkeynewsgazette.com/#logo"}},{"@type":"WebSite","@id":"https://turkeynewsgazette.com/#website","url":"https://turkeynewsgazette.com/","name":"Turkey News Gazette","publisher":{"@id":"https://turkeynewsgazette.com/#organization"}},{"@type":"WebPage","@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#webpage","url":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/","inLanguage":"en-US","name":"Saudi Commission for Health Specialties® and Prometric® Open Innovative Testing Center in Riyadh","isPartOf":{"@id":"https://turkeynewsgazette.com/#website"},"breadcrumb":{"@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#breadcrumblist"},"description":"Forward-looking design provides unparalleled access, security, and service quality  BALTIMORE, Nov. 2, 2020 /PRNewswire/ — The Saudi Commission for Health Specialties (SCFHS), in collaboration with Prometric, has opened a new professional testing center in Riyadh, Saudi Arabia.  This hallmark mega-center location incorporates innovative design elements that will significantly enhance the test taker experience, including a candidate lounge […]","datePublished":"2020-11-02T05:15:47+00:00","dateModified":"2020-11-02T05:15:47+00:00"},{"@type":"Article","@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#article","isPartOf":{"@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#webpage"},"author":{"@id":"https://turkeynewsgazette.com/author/asianet-pakistan/#author"},"headline":"Saudi Commission for Health Specialties® and Prometric® Open Innovative Testing Center in Riyadh","datePublished":"2020-11-02T05:15:47+00:00","dateModified":"2020-11-02T05:15:47+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#webpage"},"publisher":{"@id":"https://turkeynewsgazette.com/#organization"},"articleSection":"MENA, Press Release","image":{"@type":"ImageObject","@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#primaryimage","url":"https://turkeynewsgazette.com/wp-content/uploads/2020/06/turkeyng-logo.png","width":346,"height":54}},{"@type":"Person","@id":"https://turkeynewsgazette.com/author/asianet-pakistan/#author","name":"Asianet Pakistan","sameAs":[],"image":{"@type":"ImageObject","@id":"https://turkeynewsgazette.com/#personlogo","url":"https://secure.gravatar.com/avatar/fb9a54381fd455b372701227e0916124?s=96&d=mm&r=g","width":96,"height":96,"caption":"Asianet Pakistan"}},{"@type":"BreadcrumbList","@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://turkeynewsgazette.com/","url":"https://turkeynewsgazette.com/","name":"Turkey News Gazette"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/","url":"https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/","name":"Saudi Commission for Health Specialties® and Prometric® Open Innovative Testing Center in Riyadh"}}]}]}</script>
<link rel="canonical" href="https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-93844115-1', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Turkey News Gazette &raquo; Feed" href="https://turkeynewsgazette.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Turkey News Gazette &raquo; Comments Feed" href="https://turkeynewsgazette.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/turkeynewsgazette.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" href="https://turkeynewsgazette.com/wp-content/cache/minify/5507a.css" media="all" />



<link rel='stylesheet' id='colormag_google_fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.5.3' type='text/css' media='all' />
<link rel="stylesheet" href="https://turkeynewsgazette.com/wp-content/cache/minify/4bf51.css" media="all" />


<link rel="https://api.w.org/" href="https://turkeynewsgazette.com/wp-json/" /><link rel="alternate" type="application/json" href="https://turkeynewsgazette.com/wp-json/wp/v2/posts/76728" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://turkeynewsgazette.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://turkeynewsgazette.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='‫الهيئة السعودية للتخصصات الصحية® وبرومترك® يفتتحان مركز الاختبارات المبتكر بالرياض' href='https://turkeynewsgazette.com/%e2%80%ab%d8%a7%d9%84%d9%87%d9%8a%d8%a6%d8%a9-%d8%a7%d9%84%d8%b3%d8%b9%d9%88%d8%af%d9%8a%d8%a9-%d9%84%d9%84%d8%aa%d8%ae%d8%b5%d8%b5%d8%a7%d8%aa-%d8%a7%d9%84%d8%b5%d8%ad%d9%8a%d8%a9-%d9%88%d8%a8/' />
<link rel='next' title='Lists released in Chengdu offer opportunities to the world' href='https://turkeynewsgazette.com/lists-released-in-chengdu-offer-opportunities-to-the-world/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://turkeynewsgazette.com/?p=76728' />
<link rel="alternate" type="application/json+oembed" href="https://turkeynewsgazette.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fturkeynewsgazette.com%2Fsaudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://turkeynewsgazette.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fturkeynewsgazette.com%2Fsaudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh%2F&#038;format=xml" />
<script src="https://turkeynewsgazette.com/wp-content/cache/minify/c7035.js"></script>

<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://turkeynewsgazette.com/wp-content/uploads/2019/05/background.jpg"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>
	<link rel="icon" href="https://turkeynewsgazette.com/wp-content/uploads/2019/05/cropped-turkey_flag-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://turkeynewsgazette.com/wp-content/uploads/2019/05/cropped-turkey_flag-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://turkeynewsgazette.com/wp-content/uploads/2019/05/cropped-turkey_flag-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://turkeynewsgazette.com/wp-content/uploads/2019/05/cropped-turkey_flag-2-270x270.png" />
<!-- Turkey News Gazette Internal Styles -->		<style type="text/css">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</style>
				<style type="text/css" id="wp-custom-css">
			#header-text-nav-container {
    background-color: #9b9b9b;
}

#site-navigation {
    box-shadow: 0 0 2px rgba(0, 0, 0, 0.1) inset;
    position: relative;
    background-color: #f1bb00;
    border-top: 4px solid #289dcc;
}

#site-navigation {
    border-top: 4px solid #f1bb00;
}

.colormag-footer--classic .footer-socket-wrapper {
    background-color: #f1bb00;
}

.footer-socket-wrapper .copyright {
    color: #000000;
    float: left;
    font-size: 14px;
}

.footer-socket-wrapper .copyright a {
    color: #000000;
    border-bottom: 1px solid #5a5d62;
}

#site-title a, .next a:hover, .previous a:hover, .social-links i.fa:hover, a, #masthead.colormag-header-clean .social-links li:hover i.fa, #masthead.colormag-header-classic .social-links li:hover i.fa, #masthead.colormag-header-clean .breaking-news .newsticker a:hover, #masthead.colormag-header-classic .breaking-news .newsticker a:hover, #masthead.colormag-header-classic #site-navigation .fa.search-top:hover, #masthead.colormag-header-classic #site-navigation .random-post a:hover .fa-random, #masthead .main-small-navigation li:hover > .sub-toggle i, .better-responsive-menu #masthead .main-small-navigation .sub-toggle.active .fa {
    color: #f1bb00;
}

#site-navigation {
    border-top: 4px solid #9b9b9b;
}

.main-navigation a {
    color: #000000;
    display: block;
    float: none;
    font-size: 14px;
    font-weight: 600;
    padding: 10px 12px;
    text-transform: uppercase;
}

#secondary .widget-title span {
    background-color: #f1bb00;
    color: #000000;
    padding: 6px 12px;
    display: inline-block;
}

.more-link span {
    font-size: 12px;
    padding: 5px 10px;
    color: #000000;
    cursor: pointer;
    display: inline-block;
}

.widget_featured_posts .widget-title span {
    background-color: #f1bb00;
    color: #000000;
    padding: 6px 12px;
    display: inline-block;
}

.widget_featured_posts .article-content .above-entry-meta .cat-links a {
    background-color: #f1bb00;
    border-radius: 3px;
    color: #000000;
    font-size: 12px;
    padding: 3px 10px;
}

#content .post .article-content .above-entry-meta .cat-links a {
    background-color: #f1bb00;
    border-radius: 3px;
    color: #000000;
    font-size: 12px;
    padding: 3px 10px;
}

.page-header .page-title span {
    background-color: #289dcc;
    color: #000000;
    padding: 6px 12px;
    display: inline-block;
}

#content .post .article-content .entry-title {
    padding: 5px 0 0;
    font-size: 26px;
}

.colormag-button, input[type="reset"], input[type="button"], input[type="submit"], button {
    margin-bottom: 30px;
    padding: 10px 20px;
    background-color: #f1bb00;
    border: 0px;
    transition: background-color 0.3s linear 0s;
    -webkit-border-radius: 3px;
    -moz-border-radius: 3px;
    border-radius: 3px;
    font-size: 18px;
    -moz-appearance: none !important;
    -webkit-appearance: none !important;
    appearance: none !important;
    cursor: pointer;
    display: inline-block;
    color: #000000;
}
.page-header .page-title span {
    background-color: #f1bb00;
    color: #000000;
    padding: 6px 12px;
    display: inline-block;
}

.footer-socket-wrapper {
    padding: 10px 0px 10px;
    background-color: #303440;
}		</style>
		</head>

<body data-rsssl=1 class="post-template-default single single-post postid-76728 single-format-standard custom-background wp-custom-logo wp-embed-responsive  better-responsive-menu">



<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#main">Skip to content</a>

	
	
	<header id="masthead" class="site-header clearfix ">
		<div id="header-text-nav-container" class="clearfix">

						<div class="news-bar">
				<div class="inner-wrap clearfix">
					
		<div class="date-in-header">
			Monday, November 2, 2020		</div>

		
					
							<div class="social-links clearfix">
			<ul>
				<li><a href="https://www.facebook.com/Turkey-News-Gazette-460066994187904/" ><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/turkeynewsgaz" ><i class="fa fa-twitter"></i></a></li>			</ul>
		</div><!-- .social-links -->
						</div>
			</div>
		
			
			
		<div class="inner-wrap">

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://turkeynewsgazette.com/" class="custom-logo-link" rel="home"><img width="346" height="54" src="https://turkeynewsgazette.com/wp-content/uploads/2020/06/turkeyng-logo.png" class="custom-logo" alt="Turkey News Gazette" srcset="https://turkeynewsgazette.com/wp-content/uploads/2020/06/turkeyng-logo.png 346w, https://turkeynewsgazette.com/wp-content/uploads/2020/06/turkeyng-logo-300x47.png 300w" sizes="(max-width: 346px) 100vw, 346px" /></a>						</div><!-- #header-logo-image -->
											<div id="header-text" class="screen-reader-text">
													<h3 id="site-title">
								<a href="https://turkeynewsgazette.com/" title="Turkey News Gazette" rel="home">Turkey News Gazette</a>
							</h3>
																		<p id="site-description">Turkey News Gazette</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section">
											<div id="header-right-sidebar" class="clearfix">
							<aside id="custom_html-6" class="widget_text widget widget_custom_html clearfix"><div class="textwidget custom-html-widget"><!-- /30496760/turkeynewsgazette.com_468x60 -->
<div id='div-gpt-ad-1457357161759-0' style='height:60px; width:468px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1457357161759-0'); });
</script>
</div></div></aside>						</div>
										</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

		
			
			
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
									<div class="search-random-icons-container">
													<div class="top-search-wrap">
								<i class="fa fa-search search-top"></i>
								<div class="search-form-top">
									<form action="https://turkeynewsgazette.com/" class="search-form searchform clearfix" method="get">
   <div class="search-wrap">
      <input type="text" placeholder="Search" class="s field" name="s">
      <button class="search-icon" type="submit"></button>
   </div>
</form><!-- .searchform -->								</div>
							</div>
											</div>
				
				<p class="menu-toggle"></p>
				<div class="menu-primary-container"><ul id="menu-categories" class="menu"><li id="menu-item-8" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8"><a href="https://turkeynewsgazette.com/category/general/">General</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a href="https://turkeynewsgazette.com/category/production/">Production</a></li>
<li id="menu-item-47699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47699"><a href="https://turkeynewsgazette.com/category/education/">Education</a></li>
<li id="menu-item-47695" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47695"><a href="https://turkeynewsgazette.com/category/fashion-lifestyle/">Fashion &amp; Lifestyle</a></li>
<li id="menu-item-47697" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47697"><a href="https://turkeynewsgazette.com/category/health-care/">Health Care</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://turkeynewsgazette.com/category/games/">Games</a></li>
<li id="menu-item-47696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47696"><a href="https://turkeynewsgazette.com/category/foreign-affairs/">Foreign Affairs</a></li>
<li id="menu-item-47698" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47698"><a href="https://turkeynewsgazette.com/category/human-rights/">Human Rights</a></li>
<li id="menu-item-26965" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26965"><a href="https://turkeynewsgazette.com/category/press-release/">Press Release</a></li>
</ul></div>
			</div>
		</nav>

		
		</div><!-- #header-text-nav-container -->

		
	</header>

		
	<div id="main" class="clearfix">
		<div class="inner-wrap clearfix">

	
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-76728" class="post-76728 post type-post status-publish format-standard hentry category-mena category-press-release">
	
   
   
   <div class="article-content clearfix">

   
   <div class="above-entry-meta"><span class="cat-links"><a href="https://turkeynewsgazette.com/category/mena/"  rel="category tag">MENA</a>&nbsp;<a href="https://turkeynewsgazette.com/category/press-release/"  rel="category tag">Press Release</a>&nbsp;</span></div>
      <header class="entry-header">
   		<h1 class="entry-title">
   			Saudi Commission for Health Specialties® and Prometric® Open Innovative Testing Center in Riyadh   		</h1>
   	</header>

   	<div class="below-entry-meta">
			<span class="posted-on"><a href="https://turkeynewsgazette.com/saudi-commission-for-health-specialties-and-prometric-open-innovative-testing-center-in-riyadh/" title="5:15 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2020-11-02T05:15:47+00:00">November 2, 2020</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n"
					   href="https://turkeynewsgazette.com/author/asianet-pakistan/"
					   title="Asianet Pakistan">Asianet Pakistan					</a>
				</span>
			</span>

			</div>
   	<div class="entry-content clearfix">
   		<p><i>Forward-looking design provides unparalleled access, security, and service quality  </i></p>
<p>BALTIMORE, Nov. 2, 2020 /PRNewswire/ &#8212; The Saudi Commission for Health Specialties (SCFHS), in collaboration with Prometric, has opened a new professional testing center in Riyadh, Saudi Arabia.  This hallmark mega-center location incorporates innovative design elements that will significantly enhance the test taker experience, including a candidate lounge and study areas, while upholding the highest standards of assessment security and operational performance.</p>
<p>The center&#8217;s design facilitates the safe, effective administration of candidate services throughout the individual&#8217;s journey at the center, from reception and check-in through exam administration, providing an exceptional experience for each individual. The center will apply Prometric&#8217;s enhanced safety processes to maintain personal health and well-being for all visitors to the location. With multiple proctored testing rooms, the mega-center will have the ability to support more than 15,000 exams per month.</p>
<p>&#8220;We are pleased to have partnered with the Saudi Commission for Health Specialties to develop this ground-breaking professional testing location in Riyadh,&#8221; said Rudolf Tegelaar, Director Account Management Europe and Middle East for Prometric. &#8220;The operational and technological capabilities of this center will set the global standard for service quality and performance. This center will provide expanded access to the SCFHS testing program at a time of unparalleled need for trained, qualified healthcare professionals in the Kingdom and across the region.&#8221;</p>
<p>&#8220;We are proud to protect and promote health in the Kingdom of Saudi Arabia through excellence in assessments,&#8221; said SCFHS official spokesperson Mr. Fahad Al-Qathami. &#8220;SCFHS&#8217;s goals for the mega-center include providing easy access to computerized testing and offering various initiatives that elevate the client experience and promote excellence.&#8221;</p>
<p>In response to public health concerns brought on by the COVID-19 pandemic, there have been several well-thought-out precautionary measures implemented in the operation of the testing centers, including limiting initial occupancy to 50% of the maximum capacity. To ensure convenient access to testing, the center will be open 14 hours per day, seven days per week.</p>
<p>&#8220;We will continue to evaluate the client journey and ensure that anyone visiting our sites will enter as a guest and leave as a friend,&#8221; added Mr. Fahad Al-Qathami.</p>
<p><b>About Prometric<br />
</b>As a global leader in test development, testing delivery, and candidate services, Prometric partners with the world&#8217;s top credentialing and licensure organizations to design and deliver leading exam programs that help individuals advance their careers and serve their communities. Our integrated, end-to-end solutions provide exam development, management, and distribution that set the industry standard in quality, security, and service excellence. Prometric leverages our proprietary platform, advanced technologies, and vast operational experience to deliver an exceptional user experience on our world-class secure testing network. Today, we are paving the industry&#8217;s path forward with new solutions and innovation to ensure reliable access to secure assessments anytime, anywhere. For more information, visit <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=2964621-1&amp;h=3224880120&amp;u=http%3A%2F%2Fwww.prometric.com%2F&amp;a=www.prometric.com" >www.prometric.com</a> or follow us on Twitter at @PrometricGlobal and <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=2964621-1&amp;h=2787959552&amp;u=http%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fprometric%2F&amp;a=www.linkedin.com%2Fcompany%2Fprometric%2F" >www.linkedin.com/company/<wbr />prometric/</a>.</p>
<p><b>About </b> <b>Saudi Commission for Health Specialties<br />
</b>SCFHS is responsible for supervising and evaluating training programs, as well as setting controls and standards for the practice of health professions. Based in Riyadh, SCFHS was established by Royal Decree No. M/2, dated 6/2/1413 AH. SCFHS is a scientific Commission which has legal personality, and its Headquarter is located in the Diplomatic Quarter, Riyadh, with several branches across the Kingdom (Commission branches). SCFHS aims to improve professional performance, develop and encourage skills, and enrich scientific theory and practice in the different health-related fields. <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=2964621-1&amp;h=3990790133&amp;u=https%3A%2F%2Fwww.scfhs.org.sa%2Fen%2FPages%2Fdefault.aspx&amp;a=https%3A%2F%2Fwww.scfhs.org.sa%2Fen%2FPages%2Fdefault.aspx" >https://www.scfhs.org.sa/en/<wbr />Pages/default.aspx</a></p>
<p><b>Media Contacts:<br />
</b>Rudolf Tegelaar<br />
Prometric<br />
+971 4 434 5840<br />
<a href="mailto:rudolf.tegelaar@prometric.com" >rudolf.tegelaar@prometric.com</a></p>
<p>Fahad Al-Qathami<br />
Saudi Commission for Health Specialties<br />
<a href="mailto:f.salotaibi@scfhs.org" >f.salotaibi@scfhs.org</a><br />
Twitter: @FahadQathami</p>
   	</div>

   </div>

	</article>

			
		</div><!-- #content -->

      
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="https://turkeynewsgazette.com/%e2%80%ab%d8%a7%d9%84%d9%87%d9%8a%d8%a6%d8%a9-%d8%a7%d9%84%d8%b3%d8%b9%d9%88%d8%af%d9%8a%d8%a9-%d9%84%d9%84%d8%aa%d8%ae%d8%b5%d8%b5%d8%a7%d8%aa-%d8%a7%d9%84%d8%b5%d8%ad%d9%8a%d8%a9-%d9%88%d8%a8/" rel="prev"><span class="meta-nav">&larr;</span> ‫الهيئة السعودية للتخصصات الصحية® وبرومترك® يفتتحان مركز الاختبارات المبتكر بالرياض</a></li>
			<li class="next"><a href="https://turkeynewsgazette.com/lists-released-in-chengdu-offer-opportunities-to-the-world/" rel="next">Lists released in Chengdu offer opportunities to the world <span class="meta-nav">&rarr;</span></a></li>
		</ul>
	
      
      

	<h4 class="related-posts-main-title">
		<i class="fa fa-thumbs-up"></i><span>You May Also Like</span>
	</h4>

	<div class="related-posts clearfix">

					<div class="single-related-posts">

				
				<div class="article-content">

					<h3 class="entry-title">
						<a href="https://turkeynewsgazette.com/%d8%a8%d8%b1%d9%88%d9%85%d9%8a%d8%aa%d8%b1%d9%8a%d9%83-%d8%aa%d8%b9%d9%84%d9%86-%d8%b9%d9%86-%d8%aa%d8%b9%d9%8a%d9%8a%d9%86-%d8%b1%d9%88%d9%8a-%d8%b3%d9%8a%d9%85%d8%b1%d9%8a%d9%84-%d9%81%d9%8a-%d9%85/" rel="bookmark" title="بروميتريك تعلن عن تعيين روي سيمريل في منصب الرئيس التنفيذي الجديد">بروميتريك تعلن عن تعيين روي سيمريل في منصب الرئيس التنفيذي الجديد</a>
					</h3><!--/.post-title-->

					<div class="below-entry-meta">
						<span class="posted-on"><a href="https://turkeynewsgazette.com/%d8%a8%d8%b1%d9%88%d9%85%d9%8a%d8%aa%d8%b1%d9%8a%d9%83-%d8%aa%d8%b9%d9%84%d9%86-%d8%b9%d9%86-%d8%aa%d8%b9%d9%8a%d9%8a%d9%86-%d8%b1%d9%88%d9%8a-%d8%b3%d9%8a%d9%85%d8%b1%d9%8a%d9%84-%d9%81%d9%8a-%d9%85/" title="1:01 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2019-09-06T13:01:02+00:00">September 6, 2019</time></a></span>
						<span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://turkeynewsgazette.com/author/asianet-pakistan/" title="Asianet Pakistan">Asianet Pakistan</a></span></span>

											</div>

				</div>

			</div><!--/.related-->
					<div class="single-related-posts">

				
				<div class="article-content">

					<h3 class="entry-title">
						<a href="https://turkeynewsgazette.com/%e2%80%ab%d8%ac%d9%8a%d9%85%d8%a7%d9%84%d8%aa%d9%88-%d8%aa%d9%81%d9%88%d8%b2-%d8%a8%d8%ac%d8%a7%d8%a6%d8%b2%d8%a9-%d8%a7%d9%84%d8%aa%d9%85%d9%8a%d8%b2-%d9%81%d9%8a-%d8%a7%d9%84%d8%a3%d9%85%d9%86/" rel="bookmark" title="‫جيمالتو تفوز بجائزة التميز في الأمن السيبراني لعام 2017 لأفضل منتج مصادقة مع حلSafeNetKeySecure">‫جيمالتو تفوز بجائزة التميز في الأمن السيبراني لعام 2017 لأفضل منتج مصادقة مع حلSafeNetKeySecure</a>
					</h3><!--/.post-title-->

					<div class="below-entry-meta">
						<span class="posted-on"><a href="https://turkeynewsgazette.com/%e2%80%ab%d8%ac%d9%8a%d9%85%d8%a7%d9%84%d8%aa%d9%88-%d8%aa%d9%81%d9%88%d8%b2-%d8%a8%d8%ac%d8%a7%d8%a6%d8%b2%d8%a9-%d8%a7%d9%84%d8%aa%d9%85%d9%8a%d8%b2-%d9%81%d9%8a-%d8%a7%d9%84%d8%a3%d9%85%d9%86/" title="6:00 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2017-03-23T06:00:20+00:00">March 23, 2017</time></a></span>
						<span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://turkeynewsgazette.com/author/asianet-pakistan/" title="Asianet Pakistan">Asianet Pakistan</a></span></span>

											</div>

				</div>

			</div><!--/.related-->
					<div class="single-related-posts">

				
				<div class="article-content">

					<h3 class="entry-title">
						<a href="https://turkeynewsgazette.com/elin-group-places-firm-order-with-de-havilland-canada-for-three-dash-8-400-aircraft/" rel="bookmark" title="Elin Group Places Firm Order with De Havilland Canada for Three Dash 8-400 Aircraft">Elin Group Places Firm Order with De Havilland Canada for Three Dash 8-400 Aircraft</a>
					</h3><!--/.post-title-->

					<div class="below-entry-meta">
						<span class="posted-on"><a href="https://turkeynewsgazette.com/elin-group-places-firm-order-with-de-havilland-canada-for-three-dash-8-400-aircraft/" title="4:15 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2019-11-16T16:15:04+00:00">November 16, 2019</time></a></span>
						<span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://turkeynewsgazette.com/author/asianet-pakistan/" title="Asianet Pakistan">Asianet Pakistan</a></span></span>

											</div>

				</div>

			</div><!--/.related-->
		
	</div><!--/.post-related-->


      
	</div><!-- #primary -->

	
<div id="secondary">
			
		<aside id="search-4" class="widget widget_search clearfix"><h3 class="widget-title"><span>Search News</span></h3><form action="https://turkeynewsgazette.com/" class="search-form searchform clearfix" method="get">
   <div class="search-wrap">
      <input type="text" placeholder="Search" class="s field" name="s">
      <button class="search-icon" type="submit"></button>
   </div>
</form><!-- .searchform --></aside><aside id="nav_menu-3" class="widget widget_nav_menu clearfix"><h3 class="widget-title"><span>Browse Pages</span></h3><div class="menu-pages-container"><ul id="menu-pages" class="menu"><li id="menu-item-43206" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-43206"><a href="https://turkeynewsgazette.com/">Home</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22"><a href="https://turkeynewsgazette.com/about-us/">About Us</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20"><a href="https://turkeynewsgazette.com/contact-us/">Contact Us</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a href="https://turkeynewsgazette.com/submit-news/">Submit News</a></li>
<li id="menu-item-43060" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43060"><a href="https://turkeynewsgazette.com/sitemap.xml">Sitemap</a></li>
</ul></div></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html clearfix"><h3 class="widget-title"><span>Advertisement</span></h3><div class="textwidget custom-html-widget"><!-- /30496760/turkeynewsgazette.com_300x250 -->
<div id='div-gpt-ad-1457357126511-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1457357126511-0'); });
</script>
</div></div></aside><aside id="archives-5" class="widget widget_archive clearfix"><h3 class="widget-title"><span>Archives</span></h3>		<label class="screen-reader-text" for="archives-dropdown-5">Archives</label>
		<select id="archives-dropdown-5" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://turkeynewsgazette.com/2020/11/'> November 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/10/'> October 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/09/'> September 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/08/'> August 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/07/'> July 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/06/'> June 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/05/'> May 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/04/'> April 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/03/'> March 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/02/'> February 2020 </option>
	<option value='https://turkeynewsgazette.com/2020/01/'> January 2020 </option>
	<option value='https://turkeynewsgazette.com/2019/12/'> December 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/11/'> November 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/10/'> October 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/09/'> September 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/08/'> August 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/07/'> July 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/06/'> June 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/05/'> May 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/04/'> April 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/03/'> March 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/02/'> February 2019 </option>
	<option value='https://turkeynewsgazette.com/2019/01/'> January 2019 </option>
	<option value='https://turkeynewsgazette.com/2018/12/'> December 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/11/'> November 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/10/'> October 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/09/'> September 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/08/'> August 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/07/'> July 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/06/'> June 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/05/'> May 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/04/'> April 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/03/'> March 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/02/'> February 2018 </option>
	<option value='https://turkeynewsgazette.com/2018/01/'> January 2018 </option>
	<option value='https://turkeynewsgazette.com/2017/12/'> December 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/11/'> November 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/10/'> October 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/09/'> September 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/08/'> August 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/07/'> July 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/06/'> June 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/05/'> May 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/04/'> April 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/03/'> March 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/02/'> February 2017 </option>
	<option value='https://turkeynewsgazette.com/2017/01/'> January 2017 </option>
	<option value='https://turkeynewsgazette.com/2016/12/'> December 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/11/'> November 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/10/'> October 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/09/'> September 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/08/'> August 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/07/'> July 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/06/'> June 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/05/'> May 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/04/'> April 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/03/'> March 2016 </option>
	<option value='https://turkeynewsgazette.com/2016/02/'> February 2016 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-5" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside><aside id="nav_menu-4" class="widget widget_nav_menu clearfix"><h3 class="widget-title"><span>Categories</span></h3><div class="menu-categories-container"><ul id="menu-categories-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8"><a href="https://turkeynewsgazette.com/category/general/">General</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a href="https://turkeynewsgazette.com/category/production/">Production</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47699"><a href="https://turkeynewsgazette.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47695"><a href="https://turkeynewsgazette.com/category/fashion-lifestyle/">Fashion &amp; Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47697"><a href="https://turkeynewsgazette.com/category/health-care/">Health Care</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://turkeynewsgazette.com/category/games/">Games</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47696"><a href="https://turkeynewsgazette.com/category/foreign-affairs/">Foreign Affairs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47698"><a href="https://turkeynewsgazette.com/category/human-rights/">Human Rights</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26965"><a href="https://turkeynewsgazette.com/category/press-release/">Press Release</a></li>
</ul></div></aside><aside id="calendar-2" class="widget widget_calendar clearfix"><h3 class="widget-title"><span>Calendar</span></h3><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>November 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td>1</td>
	</tr>
	<tr>
		<td id="today"><a href="https://turkeynewsgazette.com/2020/11/02/" aria-label="Posts published on November 2, 2020">2</a></td><td>3</td><td>4</td><td>5</td><td>6</td><td>7</td><td>8</td>
	</tr>
	<tr>
		<td>9</td><td>10</td><td>11</td><td>12</td><td>13</td><td>14</td><td>15</td>
	</tr>
	<tr>
		<td>16</td><td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td>
	</tr>
	<tr>
		<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
	</tr>
	<tr>
		<td>30</td>
		<td class="pad" colspan="6">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://turkeynewsgazette.com/2020/10/">&laquo; Oct</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></aside>
	</div>
	

</div><!-- .inner-wrap -->
</div><!-- #main -->




<footer id="colophon" class="clearfix colormag-footer--classic">
	
	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
									</div>

				<div class="footer-socket-left-section">
										Copyright © 2020 - Turkey News Gazette. All rights reserved.
				</div>
			</div>
		</div>
	</div>
</footer>

<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

</div><!-- #page -->
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/turkeynewsgazette.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>




<!--[if lte IE 8]>
<script type='text/javascript' src='https://turkeynewsgazette.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=5.5.3' id='html5-js'></script>
<![endif]-->


<script src="https://turkeynewsgazette.com/wp-content/cache/minify/8b0a5.js"></script>

</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 
Minified using disk
Database Caching 65/80 queries in 0.273 seconds using disk

Served from: turkeynewsgazette.com @ 2020-11-02 07:32:46 by W3 Total Cache
-->